Initial conditions deleted -> error in the model

Report your bugs here.

Moderators: Frank, paul, Hiwot, Chris, peter

Buck
Posts: 15
Joined: Fri May 04, 2007 12:16 pm

Initial conditions deleted -> error in the model

Postby Buck » Thu Aug 02, 2007 4:20 pm

When editing a model with some initial conditions (due to some integrators for example),

if the initial conditions are deleted (within the editor mode, not the experiment one), then some experiments can still be launched properly but if the model is saved and closed with these conditions removed,

the model cannot then be reopened in 20-Sim ("error in the model").

A message saying that initial conditions are missing before closing the dialog box to edit them would be welcome !

Buck

paul
Posts: 152
Joined: Mon Sep 19, 2005 2:00 pm
Location: Controllab Products B.V.

Re: Initial conditions deleted -> error in the model

Postby paul » Fri Aug 03, 2007 9:50 pm

Buck wrote:When editing a model with some initial conditions (due to some integrators for example),

if the initial conditions are deleted (within the editor mode, not the experiment one), then some experiments can still be launched properly but if the model is saved and closed with these conditions removed,

the model cannot then be reopened in 20-Sim ("error in the model").

A message saying that initial conditions are missing before closing the dialog box to edit them would be welcome !


Buck, this is very strange, can you send me an example model that fails? If it is a bug, I will try to fix this for the next 20-sim 4 release.
Thanks, Paul (paul _at_ 20sim _dot_ com)
member 20-sim development team

paul
Posts: 152
Joined: Mon Sep 19, 2005 2:00 pm
Location: Controllab Products B.V.

Re: Initial conditions deleted -> error in the model

Postby paul » Tue Jan 22, 2008 5:09 pm

Found the bug and fixed it. Download the latest 20-sim 4.0 from our website and it should work just fine.
http://www.20sim.com/downloads/downloadform.html
member 20-sim development team


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest